Product SiteDocumentation Site

5.4. Manipulación de paquetes con dpkg

dpkg es el programa base para manejar paquetes Debian en el sistema. Si tiene paquetes .deb, dpkg es lo que permite instalar o analizar sus contenidos. Pero este programa sólo tiene una visión parcial del universo Debian: sabe lo que está instalado en el sistema y lo que sea que se le provee en la línea de órdenes, pero no sabe nada más de otros paquetes disponibles. Como tal, fallará si no se satisface una dependencia. Por el contrario, herramientas como apt y aptitude crearán una lista de dependencias para instalar todo tan automáticamente como sea posible.

5.4.1. Instalación de paquetes

dpkg es, sobre todo, la herramienta para instalar un paquete Debian ya disponible (porque no descarga nada). Para hacer esto utilizamos su opción -i o --install.

Ejemplo 5.2. Instalación de un paquete con dpkg

# dpkg -i man-db_2.7.0.2-5_amd64.deb
(Leyendo la base de datos ... 112846 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar man-db_2.8.5-2_amd64.deb ...
Desempaquetando man-db (2.8.5-2) sobre (2.8.5-2) ...
Configurando man-db (2.8.5-2) ...
Updating database of manual pages ...
Procesando disparadores para mime-support (3.62) ...
Podemos ver los diferentes pasos que realiza dpkg; sabemos, por lo tanto, en qué punto podría haber ocurrido un error. La instalación también puede realizarse en dos etapas: primero desempaquetado, luego configuración. apt lo aprovecha limitando la cantidad de invocaciones de dpkg (ya que cada llamada es costosa debido a la carga de la base de datos en memoria, especialmente la lista de archivos ya instalados).

Ejemplo 5.3. Desempaquetado y configuración separados

# dpkg --unpack man-db_2.7.0.2-5_amd64.deb
(Leyendo la base de datos ... 112846 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar man-db_2.8.5-2_amd64.deb ...
Desempaquetando man-db (2.8.5-2) sobre (2.8.5-2) ...
Procesando disparadores para mime-support (3.62) ...
# dpkg --configure man-db
Configurando man-db (2.8.5-2) ...
Updating database of manual pages ...
A veces dpkg fallará intentando instalar un paquete y devolverá un error; si el usuario le ordena ignorarlo sólo generará una advertencia; es por esta razón que tenemos las diferentes opciones --force-*. La orden dpkg --force-help, o su documentación, proveerá una lista completa de estas opciones. El error más frecuente, con el que seguramente se encontrará tarde o temprano, es una colisión de archivos. Cuando un paquete contiene un archivo que ya está instalado por otro paquete, dpkg se negará a instalarlo. Aparecerá el siguiente mensaje:
Unpacking libgdm (from .../libgdm_3.8.3-2_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libgdm_3.8.3-2_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/gdmflexiserver', which is also in package gdm3 3.4.1-9
En este caso, si piensa que reemplazar este archivo no es un riesgo significativo para la estabilidad de su sistema (que es el caso frecuentemente), puede utilizar la opción --force-overwrite que le indica a dpkg que ignore dicho error y sobreescriba el archivo.
Si bien hay muchas opciones --force-* disponibles, probablemente sólo utilice regularmente --force-overwrite. Estas opciones sólo existen para situaciones excepcionales y es mejor evitarlas siempre que sea posible para respetar las reglas impuestas por el mecanismo de empaquetado. No olvide que estas reglas aseguran la consistencia y estabilidad de su sistema.

5.4.2. Eliminación de un paquete

Ejecutar dpkg con la opción -r o --remove seguida del nombre de un paquete eliminará dicho paquete. Esta eliminación, sin embargo, no es completa: se mantendrán todos los archivos de configuración, scripts del encargado, archivos de registros (registros de sistema) y otros datos de usuarios que gestiona el paquete. De esta forma, puede desactivar el programa fácilmente al desinstalarlo pero es posible reinstalarlo rápidamente con la misma configuración. Para eliminar completamente todo lo asociado con un paquete, utilice la opción -P o --purge seguida del nombre del paquete.

Ejemplo 5.4. Eliminación y purgado del paquete debian-cd

# dpkg -r debian-cd
(Leyendo la base de datos ... 114438 ficheros o directorios instalados actualmente.)
Desinstalando debian-cd (3.1.25) ...
# dpkg -P debian-cd
(Leyendo la base de datos ... 113917 ficheros o directorios instalados actualmente.)
Purgando ficheros de configuración de debian-cd (3.1.25) ...

5.4.3. Consulta de la base de datos de dpkg e inspección de archivos .deb

Antes de finalizar esta sección, estudiaremos algunas opciones de dpkg que consultan la base de datos interna para obtener información. Daremos primero las opciones en su versión larga y luego la versión corta correspondiente (que evidentemente aceptarán los mismos parámetros posibles) de las opciones: --listfiles paquete (o -L), que listará los archivos instalados por este paquete; --search archivo (o -S), que encontrará el o los paquetes que contienen el archivo; --status paquete (o -s), que mostrará las cabeceras de un paquete instalado; --list (o -l), que mostrará la lista de paquetes conocidos por el sistema y su estado de instalación; --contents archivo.deb (o -c), que listará los archivos en el paquete Debian especificado; --info archivo.deb (o -I), que mostrará las cabeceras de este paquete Debian.

Ejemplo 5.5. Varias consultas con dpkg

$ dpkg -L base-passwd
/.
/usr
/usr/sbin
/usr/sbin/update-passwd
/usr/share
/usr/share/base-passwd
/usr/share/base-passwd/group.master
/usr/share/base-passwd/passwd.master
/usr/share/doc
/usr/share/doc/base-passwd
/usr/share/doc/base-passwd/README
/usr/share/doc/base-passwd/changelog.gz
/usr/share/doc/base-passwd/copyright
/usr/share/doc/base-passwd/users-and-groups.html
/usr/share/doc/base-passwd/users-and-groups.txt.gz
/usr/share/doc-base
/usr/share/doc-base/users-and-groups
/usr/share/lintian
/usr/share/lintian/overrides
/usr/share/lintian/overrides/base-passwd
/usr/share/man
/usr/share/man/de
/usr/share/man/de/man8
/usr/share/man/de/man8/update-passwd.8.gz
/usr/share/man/es
/usr/share/man/es/man8
/usr/share/man/es/man8/update-passwd.8.gz
/usr/share/man/fr
/usr/share/man/fr/man8
/usr/share/man/fr/man8/update-passwd.8.gz
/usr/share/man/ja
/usr/share/man/ja/man8
/usr/share/man/ja/man8/update-passwd.8.gz
/usr/share/man/man8
/usr/share/man/man8/update-passwd.8.gz
/usr/share/man/pl
/usr/share/man/pl/man8
/usr/share/man/pl/man8/update-passwd.8.gz
/usr/share/man/ru
/usr/share/man/ru/man8
/usr/share/man/ru/man8/update-passwd.8.gz
$ dpkg -S /bin/date
coreutils: /bin/date
$ dpkg -s coreutils
Package: coreutils
Essential: yes
Status: install ok installed
Priority: required
Section: utils
Installed-Size: 15719
Maintainer: Michael Stone <mstone@debian.org>
Architecture: amd64
Multi-Arch: foreign
Version: 8.30-3
Pre-Depends: libacl1 (>= 2.2.23), libattr1 (>= 1:2.4.44), libc6 (>= 2.28), libselinux1 (>= 2.1.13)
Description: GNU core utilities
 This package contains the basic file, shell and text manipulation
 utilities which are expected to exist on every operating system.
 .
 Specifically, this package includes:
 arch base64 basename cat chcon chgrp chmod chown chroot cksum comm cp
 csplit cut date dd df dir dircolors dirname du echo env expand expr
 factor false flock fmt fold groups head hostid id install join link ln
 logname ls md5sum mkdir mkfifo mknod mktemp mv nice nl nohup nproc numfmt
 od paste pathchk pinky pr printenv printf ptx pwd readlink realpath rm
 rmdir runcon sha*sum seq shred sleep sort split stat stty sum sync tac
 tail tee test timeout touch tr true truncate tsort tty uname unexpand
 uniq unlink users vdir wc who whoami yes
Homepage: http://gnu.org/software/coreutils
$ dpkg -l 'b*'
Deseado=desconocido(U)/Instalar/eliminaR/Purgar/retener(H)
| Estado=No/Inst/ficheros-Conf/desempaqUetado/medio-conF/medio-inst(H)/espera-disparo(W)/pendienTe-disparo
|/ Err?=(ninguno)/requiere-Reinst (Estado,Err: mayúsc.=malo)
||/ Nombre                     Versión                      Arquitectura Descripción
+++-==========================-============================-============-=================================================================
un  backupninja                <ninguna>                    <ninguna>    (no hay ninguna descripción disponible)
un  backuppc                   <ninguna>                    <ninguna>    (no hay ninguna descripción disponible)
un  balsa                      <ninguna>                    <ninguna>    (no hay ninguna descripción disponible)
un  base                       <ninguna>                    <ninguna>    (no hay ninguna descripción disponible)
un  base-config                <ninguna>                    <ninguna>    (no hay ninguna descripción disponible)
ii  base-files                 10.3+deb10u5                 amd64        Debian base system miscellaneous files
ii  base-passwd                3.5.46                       amd64        Debian base system master password and group files
[..]
$ dpkg -c /var/cache/apt/archives/gnupg-utils_2.2.12-1_amd64.deb
drwxr-xr-x root/root         0 2018-12-15 02:17 ./
drwxr-xr-x root/root         0 2018-12-15 02:17 ./usr/
drwxr-xr-x root/root         0 2018-12-15 02:17 ./usr/bin/
-rwxr-xr-x root/root      3516 2018-12-15 02:17 ./usr/bin/gpg-zip
-rwxr-xr-x root/root    866256 2018-12-15 02:17 ./usr/bin/gpgcompose
-rwxr-xr-x root/root     30792 2018-12-15 02:17 ./usr/bin/gpgparsemail
-rwxr-xr-x root/root     84432 2018-12-15 02:17 ./usr/bin/gpgsplit
-rwxr-xr-x root/root    154952 2018-12-15 02:17 ./usr/bin/gpgtar
-rwxr-xr-x root/root    166568 2018-12-15 02:17 ./usr/bin/kbxutil
-rwxr-xr-x root/root      1081 2017-08-28 12:22 ./usr/bin/lspgpot
-rwxr-xr-x root/root      2194 2018-11-18 23:37 ./usr/bin/migrate-pubring-from-classic-gpg
-rwxr-xr-x root/root    121576 2018-12-15 02:17 ./usr/bin/symcryptrun
-rwxr-xr-x root/root     18424 2018-12-15 02:17 ./usr/bin/watchgnupg
drwxr-xr-x root/root         0 2018-12-15 02:17 ./usr/sbin/
-rwxr-xr-x root/root      3075 2018-12-15 02:17 ./usr/sbin/addgnupghome
-rwxr-xr-x root/root      2217 2018-12-15 02:17 ./usr/sbin/applygnupgdefaults
drwxr-xr-x root/root         0 2018-12-15 02:17 ./usr/share/
drwxr-xr-x root/root         0 2018-12-15 02:17 ./usr/share/doc/
[...]
$ dpkg -I /var/cache/apt/archives/gnupg-utils_2.2.12-1_amd64.deb
 new Debian package, version 2.0.
 size 857408 bytes: control archive=1844 bytes.
    1564 bytes,    32 lines      control              
    1804 bytes,    28 lines      md5sums              
 Package: gnupg-utils
 Source: gnupg2
 Version: 2.2.12-1
 Architecture: amd64
 Maintainer: Debian GnuPG Maintainers <pkg-gnupg-maint@lists.alioth.debian.org>
 Installed-Size: 1845
 Depends: libassuan0 (>= 2.0.1), libbz2-1.0, libc6 (>= 2.25), libgcrypt20 (>= 1.8.0), libgpg-error0 (>= 1.26-2~), libksba8 (>= 1.3.4), libreadline7 (>= 6.0), zlib1g (>= 1:1.1.4)
 Recommends: gpg, gpg-agent, gpgconf, gpgsm
 Breaks: gnupg (<< 2.1.21-4), gnupg-agent (<< 2.1.21-4)
 Replaces: gnupg (<< 2.1.21-4), gnupg-agent (<< 2.1.21-4)
 Section: utils
 Priority: optional
 Multi-Arch: foreign
 Homepage: https://www.gnupg.org/
 Description: GNU privacy guard - utility programs
  GnuPG is GNU's tool for secure communication and data storage.
  .
  This package contains several useful utilities for manipulating
  OpenPGP data and other related cryptographic elements.  It includes:
  .
   * addgnupghome -- create .gnupg home directories
   * applygnupgdefaults -- run gpgconf --apply-defaults for all users
   * gpgcompose -- an experimental tool for constructing arbitrary
                   sequences of OpenPGP packets (e.g. for testing)
   * gpgparsemail -- parse an e-mail message into annotated format
   * gpgsplit -- split a sequence of OpenPGP packets into files
   * gpgtar -- encrypt or sign files in an archive
   * kbxutil -- list, export, import Keybox data
   * lspgpot -- convert PGP ownertrust values to GnuPG
   * migrate-pubring-from-classic-gpg -- use only "modern" formats
   * symcryptrun -- use simple symmetric encryption tool in GnuPG framework
   * watchgnupg -- watch socket-based logs
[..]

5.4.4. Archivo de registro de dpkg

dpkg mantiene un registro de todas sus acciones en /var/log/dpkg.log. Este registro es extremadamente detallado ya que incluye cada una de las etapas por las que pasa un paquete gestionado por dpkg. Además de ofrecer una forma de rastrear el funcionamiento de dpkg, sobre todo ayuda a mantener un historial del desarrollo del sistema: uno puede encontrar el momento exacto en el que se instaló o actualizó un paquete, y esta información puede ser extremadamente útil cuando se intenta entender un cambio de comportamiento reciente. Además, como se registran todas las versiones, es sencillo verificar y referenciar información con el archivo changelog.Debian.gz del paquete en cuestión o inclusive con reportes de error online.

5.4.5. Compatibilidad multiarquitectura

Todos los paquetes Debian poseen un campo «Architecture» (arquitectura) en su información de control. El valor de este campo puede ser «all» (para los paquetes que son independientes de la arquitectura) o el nombre de la arquitectura al que está destinado (como «amd64», «armhf», …). En el último caso, de forma predeterminada, dpkg sólo aceptara instalar el paquete si su arquitectura coincide con la arquitectura del equipo según es informada por dpkg --print-architecture.
Esta restricción asegura que el usuario no termine con binarios compilados para la arquitectura incorrecta. Todo sería perfecto si no fuese que (algunos) equipos puede ejecutar binarios para más de una arquitectura, ya sea de forma nativa (un sistema «amd64» puede ejecutar binarios «i386») o a través de emuladores.

5.4.5.1. Activación de multiarquitectura

La compatibilidad multiarquitectura de dpkg le permite al usuario definir «arquitecturas extranjeras» que pueden ser instaladas en el sistema actual. Puede hacer esto simplemente ejecutando dpkg --add-architecture como en el ejemplo a continuación. Existe también el correspondiente dpkg --remove-architecture para eliminar la compatibilidad de una arquitectura extranjera, pero sólo puede utilizarlo cuando ya no existan paquetes instalados de dicha arquitectura.
# dpkg --print-architecture
amd64
# dpkg --print-foreign-architectures
# dpkg -i gcc-4.9-base_4.9.1-19_armhf.deb
dpkg: error al procesar el archivo gcc-8-base_8.3.0-6_armhf.deb (--install):
 la arquitectura del paquete (armhf) no corresponde con la del sistema (amd64)
Se encontraron errores al procesar:
 gcc-8-base_8.3.0-6_armhf.deb
# dpkg --add-architecture armhf
# dpkg --add-architecture armel
# dpkg --print-foreign-architectures
armhf
armel
# dpkg -i gcc-4.9-base_4.9.1-19_armhf.deb
Seleccionando el paquete gcc-8-base:armhf previamente no seleccionado.
(Leyendo la base de datos ... 113916 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar gcc-8-base_8.3.0-6_armhf.deb ...
Desempaquetando gcc-8-base:armhf (8.3.0-6) ...
Configurando gcc-8-base:armhf (8.3.0-6) ...
# dpkg --remove-architecture armhf
dpkg: error: no se puede eliminar la arquitectura 'armhf' puesto que está en uso actualmente en la base de datos
# dpkg --remove-architecture armel
# dpkg --print-foreign-architectures
armhf

5.4.5.2. Cambios relacionados con multiarquitectura

Para poder hacer que multiarquitectura fuese útil y usable, se debieron reempaquetar bibliotecas y moverlas a un directorio específico de la arquitectura para que se pudieran instalar simultáneamete varias copias (para diferentes arquitecturas). Estos paquetes actualizados contienen el campo de cabecera «Multi-Arch: same» para indicarle al sistema de paquetes que se pueden instalar simultáneamente y sin problemas varias arquitecturas del mismo (y que dichos paquetes sólo satisfacen dependencias de los paquetes de la misma arquitectura). Las bibliotecas más importantes han sido convertidas desde la introducción de la multiarquitectura en Debian 7 Wheezy, pero hay muchas bibliotecas que probablemente nunca serán convertidas a no ser que alguien lo solicite explícitamente (mediante un informe de error, por ejemplo).
$ dpkg -s gcc-4.9-base
dpkg-query: dpkg-query: error: --status necesita un nombre de paquete legal, pero `gcc-8-base' no lo es: nombre ambiguo de paquete 'gcc-8-base' con más de una instancia instalada

Utilice --help para obtener ayuda de la consulta de paquetes.
$ dpkg -s gcc-4.9-base:amd64 gcc-4.9-base:armhf | grep ^Multi
Multi-Arch: same
Multi-Arch: same
$ dpkg -L libgcc1:amd64 |grep .so
/lib/x86_64-linux-gnu/libgcc_s.so.1
$ dpkg -S /usr/share/doc/gcc-4.9-base/copyright
gcc-4.9-base:amd64, gcc-4.9-base:armhf: /usr/share/doc/gcc-4.9-base/copyright
Vale la pena aclarar que los paquetes que contengan Multi-Arch: same deben poseer nombres que inlcuyan su arquitectura para poder identificarlos unívocamente. También tienen la posibilidad de compartir archivos con otras instancias del mismo paquete; dpkg se asegura que todos los paquetes tengan archivos idénticos bit a bit cuando son compartidos. Por último, todas las instancias de un paquete deben tener la misma versión. Por lo tanto, deben actualizarse simultáneamente.
La compatibilidad multiarquitectura también viene aparejada con algunos retos interesantes sobre la forma en la que se gestionan las dependencias. Para satisfacer una dependencia se necesita un paquete marcado con «Multi-Arch: foreign» o bien un paquete cuya arquitectura coincida con la del paquete que declara la dependencia (en este proceso de resolución de dependencias, se asume que los paquetes independientes de la arquitectura son de la misma arquitectura que el sistema). También se puede debilitar una dependencia para permitir que cualquier arquitectura la satisfaga con la sintaxis paquete:any, pero los paquetes extranjeros sólo pueden satisfacer dicha dependencia si están marcados con «Multi-Arch: allowed».